FJ Software Foren-Übersicht  
 Homepage   •  Suchen   •  FAQ   •  Mitgliederliste   •  Registrieren   •  Login
 Problem with Unicode in windows-side application Nächstes Thema anzeigen
Vorheriges Thema anzeigen
Neues Thema eröffnenNeue Antwort erstellen
Autor Nachricht
Anatolii



Anmeldedatum: 16.05.2011
Beiträge: 1

BeitragVerfasst am: Mo Mai 16, 2011 23:31 Antworten mit ZitatNach oben

Hello!

I'm from Ukrane and I'm using Russian language in my address book. But when I sync it with my laptop (locale is English in it), I have this problem:
accounts that was created in English downloaded good and I can edit it too. Accounts that was created in Russian downloads normal and shows good in list but if I want to edit account I see, for example, First Name and Last Name like this: "????????" but will be "Анатолий". And if I creating account on my laptop it shows normal in "Edit Contact" form but when I store it, in list I see this: "????????" and that can be syncing with my phone where contact store with name "????????" too.
Seems like you using different charsets in list and in "Edit Contact" form.

Please, fix it if you can.

Thanks in advance.
Best regards, Anatolii.
Benutzer-Profile anzeigenPrivate Nachricht senden
FJ
Site Admin


Anmeldedatum: 15.02.2006
Beiträge: 30450
Wohnort: Tirol

BeitragVerfasst am: Do Mai 19, 2011 22:19 Antworten mit ZitatNach oben

The list is fully unicode compatible, the text fields aren't. Set your system locale to russia
Benutzer-Profile anzeigenPrivate Nachricht sendenE-Mail sendenICQ-Nummer
K750fan



Anmeldedatum: 22.03.2010
Beiträge: 36

BeitragVerfasst am: Sa Sep 24, 2011 09:23 Antworten mit ZitatNach oben

Hi
I understand that MPE for some reason can not comprehend Russian characters if system locale is not set to Russian. My question goes for exporting messages to csv format. Is it possible to get messages in Russian displayed correctly (not just ???????????) in csv, without changing system language?
Those messages are shown fine in MPE, but export in csv doesn't work.

Thanks.
Benutzer-Profile anzeigenPrivate Nachricht senden
FJ
Site Admin


Anmeldedatum: 15.02.2006
Beiträge: 30450
Wohnort: Tirol

BeitragVerfasst am: Di Sep 27, 2011 23:40 Antworten mit ZitatNach oben

I did discuss some month ago saving the csv-Exports UTF8-encoded which allows all special characters. But the problem was that many csv-Readers does not support UTF8-encoded csv-Files so i leaved it for better compatibility

_________________
Ich bitte um Verständnis daß ich aufgrund des hohen Aufkommens im Forum und meines zeitlichen Rahmens nichtmehr jeden Thread im Forum persönlich lesen bzw. beantworten kann.

Bitte benutzt auch die Forum-Suche bzw. die FAQ
Benutzer-Profile anzeigenPrivate Nachricht sendenE-Mail sendenICQ-Nummer
K750fan



Anmeldedatum: 22.03.2010
Beiträge: 36

BeitragVerfasst am: Mi Sep 28, 2011 18:53 Antworten mit ZitatNach oben

I hope this "better compatibility" will come soon! Wink
Benutzer-Profile anzeigenPrivate Nachricht senden
sagsagman



Anmeldedatum: 23.12.2011
Beiträge: 2

BeitragVerfasst am: Fr Dez 23, 2011 00:31 Antworten mit ZitatNach oben

I'd like to add to this thread the problems I experienced with Unicode.
I'm using Win Vista, and was unable to copy to my Android phone (using MyPhoneExplorer) some files, whose names contain characters outside of my system's default codepage.

When trying to use the "upload files" action in MyPhoneExplorer, it will copy the "normal" files, but will generate an error "<file path + name> does not exist", where the shown file name has the characters outside the codepage replaced with question marks. When trying to drag & drop such files to the program, the program rejects dropping of the files.

I have no problem copying the files to my phone "normally" using MTP, and the phone plays them without any problem.

Also, MyPhoneExplorer has no problem dealing with other files containing non-latin characters, as long as they are within the system's codepage.
Benutzer-Profile anzeigenPrivate Nachricht senden
FJ
Site Admin


Anmeldedatum: 15.02.2006
Beiträge: 30450
Wohnort: Tirol

BeitragVerfasst am: So Dez 25, 2011 22:24 Antworten mit ZitatNach oben

Yes, this problem is known and i already tried to fix it. The problem is that MyPhoneExplorer is written in a old programming language and he does use alot of ANSI Interfaces. In case of filehandling i did not found a way for full unicode support

_________________
Ich bitte um Verständnis daß ich aufgrund des hohen Aufkommens im Forum und meines zeitlichen Rahmens nichtmehr jeden Thread im Forum persönlich lesen bzw. beantworten kann.

Bitte benutzt auch die Forum-Suche bzw. die FAQ
Benutzer-Profile anzeigenPrivate Nachricht sendenE-Mail sendenICQ-Nummer
MPhoneE



Anmeldedatum: 10.12.2012
Beiträge: 1

BeitragVerfasst am: Mo Dez 10, 2012 19:52 Antworten mit ZitatNach oben

FJ hat Folgendes geschrieben:
Yes, this problem is known and i already tried to fix it. The problem is that MyPhoneExplorer is written in a old programming language and he does use alot of ANSI Interfaces. In case of filehandling i did not found a way for full unicode support


Hello. Great program. Something new for those Unicode characters?
It's OK when reading SMS, when making copy-paste, but when typing in SMS window I get "?" instead of good characters
Benutzer-Profile anzeigenPrivate Nachricht senden
Beiträge der letzten Zeit anzeigen:      
Neues Thema eröffnenNeue Antwort erstellen


 Gehe zu:   



Nächstes Thema anzeigen
Vorheriges Thema anzeigen
Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.

Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme :: Alle Zeiten sind GMT + 1 Stunde
Deutsche Übersetzung von phpBB.de